Apple orders developers to use iOS7 -

The fruit themed purveyor of over-priced toys to rich Americans known as Apple has ordered developers to use its latest operating system or be purged from the istore.

Apple is now forcing developers to adopt iOS 7′s visual UI for their apps. The company has advised iOS developers that all apps submitted after February 1, 2014 must be optimised for iOS 7 and built using Xcode 5.

Apple believes that this will stop the fragmentation of products, something which plagues Microsoft and Google which have shedloads of customers using old operating systems.

The downside of course is that it means that people who do not want to upgrade, or who have machines which are too old to run it are unable to buy apps from the iStore. The spin off is that people will have to update their toys or they will not run new software.

The Tame Apple Press is presenting the change as proof of the superiority of the iOS7 which apparently was a drastic overhaul.

For example Gottabemobile said that treating customers and developers this way is "unsurprising given the push that Apple has given iOS 7 to ensure that it runs on any iOS devices–iPhone, iPad, and iPod touch".

Apple claims that it is all to allow the entire experience on an iOS device will feel more "unified and consistent". But while it seems that the Tame Apple Press gives Jobs' Mob a get out of jail free card for forcing upgrades on users who may not want them, if Microsoft told all its developers they were no longer allowed to write code for Windows 7 and must only write software that runs on the Windows 8 interface they would rightly scream "foul".